Supported Environments

DWR requires JDK 1.5 or later. Older JDK's may be used with the aid of a byte code weaver such as Retroweaver.

DWR requires a servlet engine that supports servlet spec version 2.2 or later. Earlier versions of the servlet spec may also work.

It is frequently tested in many operating environments including: